Knowledgebase: Claims
Are you compatible with the new CMS 1500 Claim Form 02-12?
Posted by on 14 Mar 2014 04:47 PM

Yes we are compatible with the new CMS 1500 Claim Form version 02-12. The new form is available on the latest version of My Vision Express 2014.

If you are not on the latest version and would like to upgrade please fill out our 2014 Upgrade Request form to begin the process of upgrading to our latest version. 

 

(1 vote(s))
Helpful
Not helpful

Copyright © 2015 Insight Software, LLC | My Vision Express